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How to add text to an image
In Adobe Photoshop, you can add text directly to an image. As with shapes, you add text in its own 
layer, which is named after the first few words of your text (Figure 1). Once you add text, you can 
change the font, modify it by using the Character and Paragraph panels, transform the text box, apply 
layer styles to the layer, or add color fonts and emojis. The only limit is your imagination.

About fonts

A font is a complete set of characters—letters, numbers, and symbols—that share a common weight, width, and style, 
such as 10‑pt Adobe Garamond Bold.

Typefaces (often called type families or font families) are collections of fonts that share an overall appearance, and are 
designed to be used together, such as Adobe Garamond. 

A type style is a variant version of an individual font in a font family. Typically, the Roman or Plain (the actual name 
varies from family to family) member of a font family is the base font, which may include type styles such as regular, 
bold, semibold, italic, and bold italic (Figure 2). If a font doesn’t include the style you want, you can apply faux styles—
simulated versions of bold, italic, superscript, subscript, all caps, and small caps styles.

Figure 1 Text added to an image, with Layers panel

Figure 2 A selection of Adobe Garamond type styles
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Typefaces include many characters in addition to the ones you see on your keyboard. Depending on the font, 
these characters can include ligatures, fractions, swashes, ornaments, ordinals, titling and stylistic alternates, 
superior and inferior characters, old‑style figures, and lining figures (Figure 3). A glyph is a specific form of a 
character. For example, in certain fonts, the capital letter A is available in several forms, such as swash and small 
cap.

To make fonts available to Photoshop and other Adobe Creative Suite applications, install them in your computer’s 
system font folder: In Windows > Windows/Fonts, or in Mac OS > Library/Fonts.

Previewing and using fonts
You can view samples of a font in the font family and font style menus in the Text options bar (Figure 4), Character 
panel and other areas in the application from where you can choose fonts. 

Figure 3 A selection of simple and decorative fonts

Figure 4 Character panel
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You can quickly access your preferred fonts by “starring” fonts as favorites. While searching for fonts, you can narrow 
down the results by filtering fonts by classification, like Serif or Sans Serif, or by visual similarity. Further, you can 
choose to search among fonts installed on your computer or synchronized fonts from Typekit. Typekit is a service 
which allows you to select, sync and use high-quality fonts in your work. Learn more about Typekit.

If more than one variant of a font family is installed on 
your computer—for example, Regular, Italic, Bold, and 
Bold Italic—the different variants are grouped under the 
same menu item. You can expand the item and select the 
desired variant (Figure 5). 

Match fonts
Sometimes you see a font you really like but you don’t 
know what font it is. Now can use Match fonts to identify 
fonts. Using just a picture of a Latin font, Photoshop CC 
can detect which font it is and suggest matching fonts 
licensed on your computer or on Typekit.

Note: Match Font, font classification, and font similarity 
features currently work only for Roman/Latin characters.

To match fonts from an existing image:

1.	 Click the Rectangular Marquee Tool from the Tools panel.

2.	 Select the area of the image containing the text whose font you want to analyze.

Some tips for selecting text for font matching:

•	 Draw the selection box, such that it includes a single line of text.

•	 Closely crop the selection box to the left and right edges of the text.

•	 Use Match Font on a single typeface and style. Don’t mix typefaces and styles inside the Match Font 
selection.

•	 Straighten or correct perspective on the image before choosing Type > Match Font.

3.	 Select Type > Match Font. Photoshop displays a list of fonts similar to the font in the image, including fonts from 
Typekit (Figure 6).

Figure 5 Font variants grouped under a menu item

Figure 6 Find fonts matching the font in an image

https://typekit.com
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If necessary, deselect Show Fonts Available To Sync 
From Typekit to view only fonts available locally on 
your computer.

4.	 In the results, click the font closest to the font in the 
image.

5.	 Click the star next to the font you’ve chosen to save it 
as a favorite.

6.	 Click OK. Photoshop selects the font you clicked.

7.	 Once the selected font is identified, return to file you 
were working on before. 

8.	 Select the Type tool and click on the text block.

9.	 In the Text options bar, select the starred, favorite font 
to apply it to the text (Figure 7).

How to add text to an image:

1.	 Open an image to which you want to add text.

2.	 Select the Type tool.

3.	 In the Text options bar, set a font family, font style, size, alignment, and color for the text (Figure 8).

Note: When you’re working with a font on-screen, you may observe that it seems smaller or larger than its 
point size. This is because the on-screen appearance of fonts depends on the document size and 
magnification. To see the font sized as it will appear when printed, choose View > Print Size.

4.	 Select an anti-aliasing option from the Anti-aliasing 
pop-up menu.

5.	 Drag on the image to draw a text box (Figure 9). 
When you are satisfied with the size of the box, 
release the mouse. 

Note: You can also click in the document to create a 
text layer. This creates a resizable text box, as opposed 
to a fixed-size text box. 

6.	 Click in the text box you’ve created and type to add 
text (Figure 10).

Figure 8 Text options bar

Tool Preset picker Set the font family Set the font size Set the text color Create warped text

Change text orientation Set the font style Set the antialiasing 
option

Set the text 
alignment

Toggle the Character 
and Paragraph panels

Figure 9 Drawing a text box

Figure 10 Adding text to a text box

Figure 7 Applying a matched and favorited font
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Modifying text by using the Character and Paragraph panels

You can change textual characteristics through the Character and Paragraph panels. These options are similar to those 
found in many word-processing and layout applications.

Modifying text by using the Character panel
To set an option in the Character panel, you first open the panel and select the text you want to change. For each 
option in the panel, choose a value from the pop-up menu (Figure 11) or type a value. When you type a value directly, 
press Enter (Windows) or Return (Mac OS) to apply it.

The options in the Character panel include the following:

•	 Font size: Depends on document size. You set font size in points.

•	 Leading: The vertical space between lines of type. You set leading in points.

•	 Kerning and Tracking: Kerning is the process of adding or subtracting space between specific pairs of characters. 
Tracking is the process of loosening or tightening the spacing between the characters in selected text or an 
entire block of text. You set tracking in points. You can also fine-tune the space between any two characters by 
selecting them and adjusting kerning. Usually you only need to adjust kerning for large font sizes—at least 16 
points.

•	 Horizontal scale: Height of the letters. You set this as a percentage.

•	 Vertical scale: Width of the letters. You set this as a percentage.

Anti-aliasing
Anti-aliasing produces smooth-edged type by partially filling the edge pixels so the edges of the type blend into the 
background. For print jobs, you will generally want to apply anti-aliasing to your text, especially for larger text since this 
subtlety softens the edge appearance of the type. For smaller text or for web images, you may want to leave anti-
aliasing turned off because blended-edge pixels on small type makes text look blurry and undefined.

•	 None: Applies no anti-aliasing.

•	 Sharp: Type appears at its sharpest. (This option is set by default.)

•	 Crisp: Type appears somewhat sharp.

•	 Strong: Type appears heavier.

•	 Smooth: Type appears smoother.

Figure 11 Character panel
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Note: When you use anti-aliasing, type may be rendered inconsistently at small sizes and low resolutions (such as the 
resolution used for web graphics). To reduce this inconsistency, deselect the Fractional Widths option in the Character 
panel menu.

To modify text by using the Character panel:

1.	 Choose Window > Character.

The Character panel appears (Figure 11).

2.	 Apply changes to the text

In the example (Figure 12), the following changes 
have been applied:

•	 Font size set to 400 pt.

•	 Anti-aliasing set to Crisp

Modifying text by using the Paragraph panel
You can make further changes to the text in the Paragraph panel (Figure 13). Most importantly, you can change the 
text’s alignment—whether the text lines up with the right, left, or center of the text box. You can also justify the text. 
Justification means spacing the text so it meets both margins.

To modify text by using the Paragraph panel:

1.	 Choose Window > Paragraph.

The Paragraph panel appears (Figure 13).

2.	 Apply changes to the text.

In the example (Figure 14), the text has been center-
aligned inside the text box.

Figure 12 Text formatted in Character panel

Figure 14 Text formatted in Paragraph panel

Figure 13 Paragraph panel
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Transforming a text box

As with most objects in Photoshop, you can transform text boxes. After you apply transformations, the text remains 
editable.

To transform a text box:

1.	 Choose Windows > Layers and confirm the text layer 
is selected (Figure 15).

2.	 Choose Edit > Free Transform.

3.	 Drag a transform control to change the shape of the 
text box.

4.	 Move the pointer over a corner of the text box until 
the pointer changes into a rotation tool (Figure 16).

5.	 Drag the rotation tool to rotate the text box.

6.	 Choose the Type tool in the Tools panel.

A message appears asking if you want to apply the 
transformation.

7.	 Select Yes (Windows) or Apply (Mac OS).

8.	 Click in the text box.

Observe that the text remains editable even while 
rotated. If you resize the text box vertically, the font 
size changes accordingly.

Figure 15 Layers panel

Figure 16 Text rotated
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Warping text

You can also curve, or warp, text by using the Create Warped Text option.

To warp text:

1.	 Select the Type tool.

2.	 Select the text you wish to warp.

3.	 Click the Create Warped Text icon in the Text options 
bar.

The Warp Text dialog box appears (Figure 17).

4.	 Select a style, such as Arc.

5.	 Choose Bend, Horizontal, and/or Vertical to deter‑
mine a direction for the warp.

6.	 Select a degree of bend for the warp.

7.	 Change the Horizontal Distortion and Vertical 
Distortion.

These settings let you create asymmetrical warps in 
either a horizontal or vertical direction. You can 
experiment with these settings later, but for now, keep 
the warp straightforward.

8.	 Click OK to apply the warp (Figure 18).

Figure 18 Text with Wave warp applied

Figure 17 Warp Text dialog box
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Modifying text by using layer styles

Because text is added to its own layer, you can also change the appearance of text by using layer styles. You can add a 
drop shadow to the text, make the text appear embossed or beveled, or outline each letter with a stroke.

To modify text by using layer styles:

1.	 If the Layers panel is not already visible, choose Window > Layers.

2.	 Double-click the text layer to open the Layer Style dialog box (Figure 19).

Layer Styles appear in a column on the left. To apply a style, check its box. You can also reveal options for 
modifying a style by clicking its name.

3.	 Apply one or more layer styles to the text.

Outer Glow, Bevel, Contour, and Stroke have been 
applied to the text in the example (Figure 20).

Figure 20 Layer effects applied to text

Figure 19 Layer Style dialog box

Check a box 
to apply style

Click a style’s 
name to 

modify 
options for it

Layer style 
preview



10How to add text to an image  Photoshop Guide© 2016 Adobe Systems Incorporated. 
This document requires Adobe Photoshop CC 2017. Technical instructions may differ depending on your version.

Reusing text formats with type styles
You can achieve a consistent look and feel with saved type styles, which let you apply formatting to selected 
characters, lines, or paragraphs of text with a single click.

A character style is a collection of character-formatting attributes that you can apply to a selected range of text. A 
paragraph style includes both character- and paragraph-formatting attributes and can be applied to a selected 
paragraph or range of paragraphs.

To use type styles:

1.	 Create a paragraph of text in your image.

2.	 Choose Window > Paragraph Styles.

The Paragraph Styles panel opens (Figure 21).

3.	 To create a new paragraph style, click the Create New 
Style button.

4.	 Double-click the new style in the Paragraph Style 
panel.

The Paragraph Style Options dialog box opens (Figure 
22).

5.	 Type a new Style Name, if desired.

6.	 Define the text and paragraph options you want in the 
Paragraph Style Options dialog box and then click OK.

7.	 Select the text paragraph again.

8.	 Create a second paragraph style in the same way.

9.	 To apply a paragraph style, select a character, line, or 
paragraph of text and click a style name in the 
Paragraph Styles panel (Figure 23).

Note: You can update any of the paragraph styles you 
create by double-clicking the style name and editing 
the options you want in the Paragraph Style Options 
dialog box. A plus sign next to a style name in the 
Paragraph Styles panel indicates that a style has been 
overriden, or modified in the document. To clear 
overrides and return text to the appearance defined 
by the style, click the Clear Modification button. To 
redefine the style and maintain the current text 
appearance, click the Redefine button.

Figure 22 Paragraph Style Options dialog box

Figure 23 Paragraph Styles panel

Figure 21 Paragraph Styles panel
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Colored fonts and emojis

Adobe’s new color fonts are a fun and easy way to enhance your design projects. While this experimental typeface is 
still early days, it points to exciting and innovative developments for new font technology for designers and graphic 
artists. 

Photoshop comes with two fonts installed, Trajan Color Concept and EmojiOne Color. These fonts use built-in 
OpenType-SVG technology (OpenType is a format for scalable computer fonts, SVG stands for Scalable Vector Graphics). 
This new standard changes font appearance by using color and pattern effects built right into the font file (Figure 24). 
Download the emoji file used in this step-by-step section here. Learn more about OpenType-SVG here and test out 
color fonts on this demo page.

Color fonts like Trajan Color Concept and EmojiOne Color appear just like typical fonts in Photoshop’s font menus. The 
Trajan Color Concept font allows you to choose from nineteen different colors and textures. Using Emoji fonts, you can 
include various colorful and graphical characters, such as smileys, flags, street signs, animals, people, food, landmarks 
in your documents. You can also use the Glyphs panel to preview and insert color fonts and emoji into your document.

To use OpenType SVG fonts:

1.	 Select the Type tool and either drag to create either a 
paragraph layer, or click to create point-text type layer.

2.	 Set the font to an OpenType SVG font. These fonts are 
marked with an OpenType symbol and “SVG” within 
the font list (Figure 25).

Figure 25 Font menu with OpenType SVG font selected

Figure 24 Color fonts and emoji in Photoshop

http://adobe.ly/2gMZ8vl
https://helpx.adobe.com/typekit/using/ot-svg-color-fonts.html
https://color.typekit.com
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3.	 If not already open, select Window > Glyphs to view 
the Glyphs Panel (Figure 26). 

4.	 Type using the keyboard or select specific glyphs using 
the Glyphs Panel. 

5.	 To change the color of the individual letters, use the 
Glyphs panel scroll bar to review other options and 
double-click to change the color.

You can also use the text cursor to select individual 
letters. This reveals a pop-up selection panel where 
you can choose from teh available letter color 
variatons (Figure 27).

How to add a watermark to images

When showing others your work, or the work of others, it can be good idea to apply a watermark to images so 
intellectual property  is protected. A watermark is a partly visible message that marks the image as belonging to you or 
giving credit to the appropriate creator.

You can apply a watermark in several ways. Most of these involve placing the watermark in a layer above the image 
itself and then formatting the watermark’s layer so the image is visible through the watermark. One way to format the 
layer is by reducing its opacity. Opacity refers to a layer’s degree of transparency. You set layer opacity through the 
Layer Style dialog box.

Figure 26 Glyphs panel

Figure 27 Select color font using pop-up selection panel

Scroll 
bar



13

For more information
Get instant access to free courses, workshops, & 
teaching materials and connect with the creative 
education community on the Adobe Education 
Exchange: https://edex.adobe.com/.

Adobe Systems Incorporated 
345 Park Avenue 
San Jose, CA 95110-2704  
USA 
www.adobe.com

Adobe and the Adobe logo are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States 
and/or other countries. All other trademarks are the property of 
their respective owners.

© 2016 Adobe Systems Incorporated. All rights reserved.

This work is licensed under a Creative Commons Attribution-
Noncommercial-Share Alike 3.0 Unported License.

Adding a watermark to an image:

1.	 Open an image to which you’d like to add a watermark

2.	 Select the Type tool from the Tools panel.

When you select the Type tool, the Options bar 
changes to the Type options bar. The Type options bar 
should appear at the top of the workspace (Figure 28). 
If you do not see the Type options bar, choose 
Window > Options.

3.	 In the Type options bar, set a font family, font style, 
size, alignment, and color for the text. Make the font 
size relatively big and the font color relatively contrast‑
ing (dark on a light background, or light on a dark 
background), so readers will be able to see the text 
over the image.

4.	 Drag on the image to draw a text box.

5.	 Click in the text box you’ve created and type a copy‑
right message, such as “Photo credit: NASA” and adjust 
the fonts as needed.

Next, you’re going to make the message translucent so 
viewers can still see the image. You’ll do so by 
changing the style of the type layer.

6.	 Choose Layer > Layer Style > Blending Options. The 
Layer Style dialog box opens (Figure 29).

Note: You can also double-click on the layer in the 
Layers panel to open the Layer Style dialog box.

7.	 Select the Preview option.

This option lets you view the effects of your changes 
as you make them.

8.	 Drag the Opacity slider to the left until you are 
satisfied with the visibility of the copyright message.

9.	 Select OK to close the Layer Style dialog box. The 
watermark appears over the image (Figure 30).

Observe that the image is still partly visible through the text. This is because you reduced the text’s opacity.

Figure 30 Watermarked image

Images courtesy NASA, 
https://www.nasa.gov/multimedia/imagegallery/index.html

Figure 29 Paragraph Style Options dialog box

Figure 28 Tools panel

https://edex.adobe.com/
https://creativecommons.org/licenses/by-nc-sa/3.0/
https://creativecommons.org/licenses/by-nc-sa/3.0/
https://www.nasa.gov/multimedia/imagegallery/index.html
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